Архив метки: звук

Чистка кармы windows-машины Убунтой

Странный немного случай тут приключился. Продал когда-то давно знакомому Audigy 1. Работала себе вполне успешно несколько лет вместо сдохшей встроенной, пока внезапно не пропал звук. При тесте звука из динамиков лишь какие-то потрескивания. «Вероятно, спалил и эту карту» — решили и начали искать замену.

Те PCI-карты, что у меня были, завести на Windows 7 не удалось — не было драйверов. Знакомый купил дешевую USB-карту, но звук не понравился. Попросил найти другую. Нашел такую же Audigy 1, как у него была. Отдал, тот поставил, повозился, звонит — нет звука.

Приехал я, поставил — вместо звука какие-то сильные шумы, как будто вместо аналогового выхода используется цифровой. Полез смотреть драйвер — там что-то не то. Ткнул «Обновить» — начал ставиться драйвер, после чего появилось корректное название карты. Проверка — и звук пропал совсем. Снова какие-то щелчки и больше ничего. Либо железо выгорает из-за внешних условий (мало ли, не то напряжение на карту приходит), либо…

Под рукой не было другой системы, хотя обычно таскаю с собой флешку с Убунтой. Скачал Убунту, залил на флешку Rufus’ом (уж что было под рукой — и да, оно так тоже работает). Винда, стоит заметить, давно уже просилась на покой — какая-то дрянь жрет проц, тормоза и так далее.

Открываю в Убунте youtube, лезу в настройки, тыкаю вывод через Audigy (плюсик pulseaudio) — и слышим нормальный звук. Ставлю старую карту — тоже звук есть.

Самое интересное получилось при перезагрузке в винду. Звук появился и там. Почему — непонятно. Настройки — не менялись. Система пережила перестановки двух одинаковых карт в разные PCI-слоты, сносы и обновления драйверов, тесты всех мыслимых вариантов конфигурации карт, а вылечилось все простым запуском плеера в Linux’e.