Развернул NVC на криптохосте

Добавил наконец-то NVC. В отличие от остальных валют, пришлось добавлять кучку либ руками. Плюс, несмотря на «Пакет для Debian», novacoind требует либы, которых в репозитории Debian’а просто нет.

Итого: для Debian 9 надо поставить libssl1.0.0 и ряд libboost из Debian 8, плюс для всех требуемых libboost* посоздавать симлинки на версию 1.5.4:

sudo apt-get install libssl1.0.0 libboost-filesystem1.55.0 libboost-program-options1.55.0 libboost-system1.55.0 libboost-thread1.55.0

rain@megacache:~$ ls -l /usr/lib/x86_64-linux-gnu/libboost_*
lrwxrwxrwx 1 root root 29 фев 6 01:15 /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.54.0 -> libboost_filesystem.so.1.55.0
-rw-r--r-- 1 root root 97504 сен 19 2014 /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.55.0
lrwxrwxrwx 1 root root 34 фев 6 01:16 /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.54.0 -> libboost_program_options.so.1.55.0
-rw-r--r-- 1 root root 492144 сен 19 2014 /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.55.0
lrwxrwxrwx 1 root root 51 фев 6 01:13 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.54.0 -> /usr/lib/x86_64-linux-gnu/libboost_system.so.1.55.0
-rw-r--r-- 1 root root 14552 сен 19 2014 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.55.0
lrwxrwxrwx 1 root root 25 фев 6 01:17 /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.54.0 -> libboost_thread.so.1.55.0
-rw-r--r-- 1 root root 109656 сен 19 2014 /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.55.0

После этого все работает.

С версиями libboost из Debian 9 (1.62) кошелек запускаться отказался.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *